If you receive this error message when running a profile then you are using the wrong version of SyncBackPro or SyncBackSE. Starting with V5.8.5.0 you must download and install a version that is specifically created for Windows 2000:

SyncBackPro: https://www.2brightsparks.com/assets/software/SyncBackPro_Setup_2K.exe
SyncBackSE: https://www.2brightsparks.com/assets/software/SyncBackSE_Setup_2K.exe

Note that we no longer support Windows 2000 on any version of SyncBack (Free, SE or Pro). The above downloads (and this article) are intended only for existing V5 / Windows 2000 users who need to re-install for some reason, and who already have a compatible V5 serial number. V5 serial numbers are no longer for sale or otherwise available, as the serial-encoding is different in V6 and the mechanism to generate serial numbers is now V6, not V5.