Overview


When using a SYSTEM or SERVICE account to run a SyncBack scheduled task, the task is not running/starting.


Cause


When a SyncBack profile is created by the user, they are stored under the Windows user account that was used to create the profile. The storage location of the profile is stored by default in the following path:


C:\Users\USERNAME\AppData\Local\2BrightSparks\SyncBack\


where [USERNAME] is the Windows account used during the profile creation.


A Scheduled Task running under SYSTEM account will cause SyncBack to look for profiles under an equivalent path, such as:


C:\Users\SYSTEM\...


which doesn't exist, therefore the scheduled task will fail to start since there are no relevant files to call SyncBack under this path.


One option is to set the profile storage location to a universally accessible or 'common' folder (such as the Program folder). However, the problem is that it's not possible to change the per-SyncBack-user program settings to allow the SYSTEM account to store profiles in the program folder without logging in interactively as SYSTEM and running SyncBack/making those storage-settings changes for the user involved (same applies regarding profile logs storage, which is set by default to C:\Users\USERNAME\...\Logs\...). It is also not possible to log in interactively under the SYSTEM account.


There is also the problem "Where would SB store the INI file (SETTINGS.INI per named user) containing these customized storage settings?". Since it would need to also use C:\Users\USERNAME\....\SyncBack\ but as it's not possible to log-in/run SyncBack interactively as SYSTEM, it would not be able to create the per-user INI file...


Solution/Workaround


SyncBack is not designed to be run under a SYSTEM (or similar) account. The best solution is to use the original Windows account used to create the SyncBack scheduled task and not use a SYSTEM account. If this is not possible due to security concerns, the alternative would be to use a non-SYSTEM Windows account and change the profile storage location to a common folder using the instructions in this article.


Note that you need to assign full write/change privileges for that 'common' folder to any account that will create or run profiles; if SyncBack detects you do not have these privileges, it will not permit you to choose that storage option.