Problem:

When your Upgrade Assurance subscription is automatically renewed using your credit card, you receive an email notification that the renewal process failed.


Cause:

The card issuing bank is stopping the transaction and returning a transaction failure message to our payment processor, FastSpring. As a result, FastSpring sends an automated renewal failure email to notify you.


There are several reasons why the payment was declined. Here are the most common reasons:


- Invalid credit card number or billing address was entered

- Incorrect or expired expiration date

- A hold has been placed on the account

- Insufficient funds

- A restriction may have been placed on the account. For example, the account cannot be used outside the country where the card was issued or online purchases are not allowed


Solution:

Please check with your bank to find out why they are returning an error message during your online purchase. If there is a reason the bank is blocking the transaction, you have to instruct the bank to clear the block first before proceeding with another purchase attempt.


Alternatively, you can also try using a different credit card to renew your subscription.


<How to use a different credit card for subscription renewal>

The renewal for Upgrade Assurance subscription is performed automatically by FastSpring. You can reset/change your credit card re-billing by logging into your FastSpring Account Portal, remove the existing credit card, and add a new payment method.


Login to your account portal by going to this website:

https://2brightsparks.onfastspring.com/account/


Submit your email address (the email that was used to place your order) and an email with a link to access your Account Portal will be sent to this address.


1. Click on the link to go to the Account Portal and select the "Account Details and Payment Methods" tab.

2. Click on "Manage > Remove" to remove your current/existing payment method.

3. Click on "Add Payment Method" button, then Check the box "Apply to all my subscriptions" option, and finally add your new payment method (Credit Card).


Once the new payment method is added, the renewal charge will be automatically charged and a confirmation email with an invoice will be sent to you.


Contact Support

If the above steps did not help, please Contact Support for further assistance.